What's new
  • Hey Guest!

    Our hosting provider or CloudFlare won't reply to any DMCA takedown notice!

    If you wish TakeDown of your resource then,
    Contact us at discord: TheSpace#7021


    Please allow up to a week for a discord reply!
  • Hey Guest !

    In order to be able to download resources,
    You need to register. Register by the Button at upside at right.

    Thanks for reading me :)
  • Hey Guest !

    Please don't use randomly generated or written names (example: dfdfasdf)
    We'll ban users with those names because they're Spam-Like.
    To prevent this! Please use normal names while registration!
PhasmatosEnchantsGUI - Buy enchants in gui for level or money! [50% Christmas Sale]

Nulled PhasmatosEnchantsGUI - Buy enchants in gui for level or money! [50% Christmas Sale] 4.1

No permission to download
Have you ever wanted to have a control while choosing enchants (in enchantment table)?
  • With this plugin your players are able to choose enchant in gui and buy it for level or money, depending on your configuration.
  • If they click on the enchant - old enchants gui will not open - instead of it - new enchant gui will open to the player and he will can choose enchant.
  • The basic moneymanager is based on vault, so if you are using "money" in enchants you need to install Vault plugin.
  • Whole plugin is configurable! You can add a lot of enchants, change the gui and even add your own "money manager" if you are developer, the code is clean and easy to read.
Configuration:
Code (Text):
enchants:
damage_6:
enchant:
name: DAMAGE_ALL
level: 6
slot: 0
required-bookshelves: 5
cost:
level: 5
name: Sharpness VI
item:
name: '&aSharpness VI'
lore:
- '&7Cost: &65 levels'
- ''
- '{CAN-BUY}'
material: ENCHANTED_BOOK
damage_7:
required-bookshelves: 6
enchant:
name: DAMAGE_ALL
level: 7
slot: 1
cost:
money: 150.0
name: '&aSharpness VII'
item:
name: '&aSharpness VII'
lore:
- '&7Cost: &6150 money'
- ''
- '{CAN-BUY}'
material: ENCHANTED_BOOK
damage_8:
required-bookshelves: 7
enchant:
name: DAMAGE_ALL
level: 8
slot: 2
cost:
money: 200.0
level: 6
name: Sharpness VIII
item:
name: '&aSharpness VIII'
lore:
- '&7Cost: &66 levels and 200 money'
- ''
- '{CAN-BUY}'
material: ENCHANTED_BOOK
Code (Text):
enchants-inventory:
title: '&8List of enchants'
size: 9
messages:
purchase-successfully: '&aYou purchase &6{ENCHANT} &aenchant!'
purchase-error: '&cYou cannot buy this enchant! Check your level or money!'
must-hold-something: '&cYou have to hold something in your main hand!'
yes-message: '&eClick to purchase!'
no-message: '&cYou dont have enough money!'
cannot-enchant-this-item: '&cYou cannot enchants this item!'
no-bookshelves: '&cToo few books around enchant!'
no-permission: '&cYou dont have permission!'
no-console: '&cThis command cannot be used as a console!'
commands:
descriptions:
admin:
list: '&f&oLists currently available enchants!'
reload: '&f&oReloads the plugin'
reload-success: '&aSuccessfully reloaded!'
Code (Text):
# Format: '{sound},{pitch},{volume}' (I wish you a pleasant config fix)
invalid-sound-replace: true
invalid-sound-replace-approximate: true
invalid-sound: none,0f,0f
sounds:
purchase: NOTE_PLING,1.0f,2.0f
notenoughmoney: ENDERMAN_TELEPORT,1.0f,0.5f
musthold: ENDERMAN_TELEPORT,1.0f,0.5f
cannotenchant: ENDERMAN_TELEPORT,1.0f,0.5f
nobook: VILLAGER_NO,1.0f,1.0f

Remember that by purchasing this plugin you accept the following terms and conditions.
  1. You are over 18 or have your parent's consent to purchase.
  2. You aren't allowed to redistribute this plugin.
  3. You aren't allowed to modify the code.
  4. These terms are subject to change.
  5. You aren't able to receive the source code.
  6. You can use it only for your server or network.
  7. Before reviewing the plugin, check out him and make sure you make no mistakes.
  8. Don't make stupid reviews, such as missing features or the developer aren't adding features that were requested.
  9. If there is a plugin error, it is your responsibility to inform the developer about it.
  10. No refunds.
  11. If you are caught leaking the plugin your user ID will be blocked and you will be reported to SpigotMC Staff.
  12. The word "leak" in the plugin name is used only for marketing purposes.
Author
𝓣𝓱𝓮𝓢𝓹𝓪𝓬𝓮
Downloads
16
Views
190
First release
Last update
Rating
0.00 star(s) 0 ratings

Latest updates

  1. 4.1

    PhasmatosEnchants | 4.1 ⦁ Improved code and update
  2. 4.0

    PhasmatosEnchants | 4.0 ⦁ Added Enchant Hologram
  3. 3.9

    PhasmatosEnchants | 3.9 ⦁ Fixed a bug where the EnchantOpenEvent api was not working properly
Tags
None